I remember an old mentor programmer I had who basically described his job as building an addition to an addition to an addition on a tree house built in a twig.
Programmer Humor
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
Rules
- Keep content in english
- No advertisements
- Posts must be related to programming or programmer topics
Wait, what do you mean x3, y2, and x37 are not good variable names?
Vedal made this post
Who? I made this you can tell by the imgflip in corner and PNG spaghetti xD...
T'was a joke. He's a programmer guy on Youtube who uses a turtle avatar.
Ahh ok:p my bad xD.. I was like I made this shitty meme no way someone stole it!
All these jokes about naming variables and yet no serious suggestions that if you have a turtle2, what you really need is a turtle array. I like to block out all the memory I'll need for the whole program up front, put it all in one big array, and then I can use clean, easy to remember numbers for all my variables!
All great code started out as a shitty work-around that happened to work.
(I say this as someone with one of the more prestigious pedigrees in "not writing shit code". All the theory I've learned helps, but at the end of the day the most important qualities of a line of code are: whether it got the job done, and whether is was obviously correct enough that the next developer left it alone.)
Because I mostly (almost exclusively) write shell scripts, my vars are often like this: theList
, workingDir
, etc.
I'm a monster. But it works for me.
This is a very cute thread. I love turtles and I like them for their vast computer science skills too.
Based LOGO programmer.
An array?
var turtles = new Turtle[] { new Turtle(), new Turtle() };
Don't do this :P
But I like tautological variable names
also turtles
Fucking mathematicians
What's wrong with making a recursive function in a recursive function with variables M, m, N, n? It's perfectly fine when I'm writing infinite series.
If we're talking mathematicians, you just know it's going to be ω-nested recursive functions any moment now. Just be grateful it's not all n with polynomial subscripts or something.
Polynomial subscripts sound awesome, ngl. Never seen it before; I want to know what the applications are.
Uhh, I'm pretty sure I've seen that, but I'm not sure where now. Any time you need to access a member of a list or array that's determined by a polynomial - which by Horner's rule covers all combinations of multiplications and additions - it would be a possible notation.
Transfinite algorithms are definitely a topic of research.
Try assembly language! You have registers, and they are named for you with highly memorable names like R17.
ngl RAX actually sounds cool and is memorable 🥺
RIP.
Don’t recommend using that register to store your variables.
Yes your variable names should indeed all be different from one another.
var Turtle1 var Turtle1 var Turtle1
just doesn't quite have the same impact:-).
I always make sure my variables are named in ways I can remember what they're for. The only time I just use generic var1, var2, etc is if I am experimenting with a function I've never used before and wanna play around with it to see how it's used.
This should be easily read by others but there could be times where it's an inside joke.
Yes, its code whether it executes or not.
The word 'code' has many different definitions. The shaolin martial arts tournament is governed by a system of rules of conduct
...an ethical code.The combatants respect each other as warriors, no matter what degree of hatred they have for one another
...a code of honor.Another type of code could be defined as an arbitrary system of symbols or letters for transmitting messages
...a secret code.Mortal Kombat(tm) adheres to many codes, but does it contain one?
Yes, more code
Yeah, a name should describe what it is or does, so if you have two turtles, and let's say turtle1 wants to shit on turtle2's lawn, you could name them shittingTurtle and victimTurtle. If the name alone tells you what its purpose is, that saves a lot of time for people looking at your code.
Is_Turtle is not a bad variable name because it tells you it is a Boolean with "is" and that the Boolean tells you whether something is a turtle or not.
Also, depending on the language, I suggest either camelCase or snake_case naming of variables. PascalCase is usually for defining classes or in case of C#, methods.
Thank you for this. This is awesome.
shittingTurtle
and victimTurtle
are going into one of my professional slide decks as soon as I think I can get away with it.
SHOUTING_SNAKE_CASE aka SCREAMING_SNAKE_CASE is the best case for all use cases, because it gives you a chance to use its wonderful names.
I prefer REVERSEcAMEL
Thanks. I hate it.
I consider myself a collector of programming anti-patterns, but I didn't have this one yet.
I'm gonna be honest I just used Turtle:X .. when it's actually like a GoldCost, GoldC and GoldH. Where GoldR is a reset var and GoldC is the paid value. GoldCost is self explanatory but I really mudddied it up XD...