I know I'm late to this but here's my (probably insane?) take. We use Subject-Verb-Object in English right? So, hear me out:
dialog_create_tab(...)
dialog_open_file(...)
dialog_close_file(...)
Welcome to Programmer Humor!
This is a place where you can post jokes, memes, humor, etc. related to programming!
For sharing awful code theres also Programming Horror.
I know I'm late to this but here's my (probably insane?) take. We use Subject-Verb-Object in English right? So, hear me out:
dialog_create_tab(...)
dialog_open_file(...)
dialog_close_file(...)
I just name my variables a, b, c etc. If I have more than 26 variables in any given function, I name them aa, ab, ac, etc.
you're on a highway to hell.
in general, adjectives and verbs after nouns because it's more organized/easier to search/filter. as god intended.
Both:
dialog_error = Dialog_plain.create_modal(error_text)
Variable and class names go from more general to more particular, functions begin with a verb.
Global functions are either "main", or start with one of "debug", "todo", or "shit".
Powershell has a lint warning for functions that don't follow Verb-Noun format, and verbs here are a list of approved verbs lol
We just call those Smurf names.
I personally prefer dialogs.FileDialog.open()
I know the second one is better, but I also know I'm terribly inconsistent with this stuff.
Been learning to program and I'm refusing to use an lsp for the time being. I'm bad about using abbreviated names when I have to type over and over again(no auto complete). I'm at least using descriptive names for functions I use less than four times.
I'm truly torn with this. The first one seems sensible (action -> target) and easier to read and reason about (especially with long names), while the other one looks more organized, naturally sortable and works great with any autocompletion system.
Not a programmer, but I'd prefer right naming convention because sorting
I am a programmer, and i also like the naming scheme on the right
Especially for things like filenames
Also a programmer and think method names would be conducive using little endian.
TopicGet()
TopicCreate()
TopicDelete()
Writing this I realize we do this implicitly in some instances.
http.Get() -> httpGet()
http.Post() -> httpPost()
We need a new framework, one that allows universal lookup, and makes life easier
x = _.dialog.file.open
y = _.open.file.dialog
z = _.file.open.dialog
a = _.file.dialog.open
Once done, the formatter simply changes everything to _.open.file.dialog
Let's get this done JS peeps
\s
Aahh you can't just make this problem object oriented!
C programmers don't like that.
the people who chose the first one...who hurt you?
Powershell
No one, it just makes sense.
You must be one of those "Throw your mother downstairs, the box of tissues" types.
Yoda sounded normal to you I bet.
reverse polish notation time
It makes sense until you write 30 methods to manipulate the data layer.
Fuzzy search solves this pretty good
I will
Not new
Romance language word order noun_descriptor is the right way.